Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Discover Pro (MIB2.5) Stuck on boot splash screen

  1. #1
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag

    Discover Pro (MIB2.5) Stuck on boot splash screen

    So I installed mib2-toolbox this afternoon. While checking out the settings it has available I must have done something wrong as my Discover Pro (MIB2.5) is now stuck on the boot splash screen.

    The big problem is because I can't access any of the device menus I can't get back into the green developer menu to undo what I've done, nor can I enter the service menu to reflash firmware and overwrite back to factory default.

    Any suggestions on what I can do here please?

  2. #2
    Join Date
    Jun 2010
    Location
    Sydney
    Posts
    3,895
    Users Country Flag
    Buy yourself a bench harness and the appropriate TTL to USB adapter and access the device over the debug pins so you can restore your backup from sdcard that you took before attempting to modify anything.
    2011 Skoda Octavia vRS TDI DSG wagon|Revo Stage 1|Race Blue|Leather|Dynamic Xenons w 6000K|9w7 BT|THA475 Amp+active sub|Whiteline ALK|RVC|
    2009 R36 wagon|Biscay Blue|RVC|Tailgate|ECU and DSG tune|LED DRL/Indicators|3D colour cluster|Quad LED tail rings|Climatronics upgrade|Dynaudio retrofit|B7 RLine Flat Steering Wheel|3AA CCM|TPMS Direct|B7 Adaptive Cruise with Front Assist|Discover Media retrofit|PLA 2.0|Lane Assist|BCM retrofit|High Beam Assist|DQ500

  3. #3
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter
    Hey Kamold - thanks for the response. Sorry but the instructions are a bit vague. Happy to listen and follow instructions from those more learned than me, but I'm far from an expert �� What is it exactly you're instructing me to do?

  4. #4
    Join Date
    Jun 2010
    Location
    Sydney
    Posts
    3,895
    Users Country Flag
    You need to build/buy a harness to power the unit on whilst on the bench. Connect a serial adapter to the debug pins on the back of the unit and then access it over telnet. Then you can use the command line to restore the files you backed up before modifying the unit.
    If you didn't back anything up then best bet is force it into emergency SWDL mode and reload the current firmware version to overwrite whatever it is you broke.
    2011 Skoda Octavia vRS TDI DSG wagon|Revo Stage 1|Race Blue|Leather|Dynamic Xenons w 6000K|9w7 BT|THA475 Amp+active sub|Whiteline ALK|RVC|
    2009 R36 wagon|Biscay Blue|RVC|Tailgate|ECU and DSG tune|LED DRL/Indicators|3D colour cluster|Quad LED tail rings|Climatronics upgrade|Dynaudio retrofit|B7 RLine Flat Steering Wheel|3AA CCM|TPMS Direct|B7 Adaptive Cruise with Front Assist|Discover Media retrofit|PLA 2.0|Lane Assist|BCM retrofit|High Beam Assist|DQ500

  5. #5
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter
    Ah now I'm with you! Thanks. I know that MIB2-toolbox's dev jilleb states over on his github that you can telnet in using a D-Link Dub-E100 usb to ethernet adapter - so that would would be much more preferable to pulling the whole thing out.

    Do you have any information on how to force SWDL mode? I'm happy to wipe everything back to factory default if its the easiest solution.

  6. #6
    Join Date
    Jun 2010
    Location
    Sydney
    Posts
    3,895
    Users Country Flag
    If you can find one of the Dlink adapters. They have been out of production for a while.
    To get it into emergency SWDL mode you need to have the unit on the bench. Need to short the debug RX pin to ground for 5000ms at boot and then return it back to the serial connection you will have the recovery menu.
    2011 Skoda Octavia vRS TDI DSG wagon|Revo Stage 1|Race Blue|Leather|Dynamic Xenons w 6000K|9w7 BT|THA475 Amp+active sub|Whiteline ALK|RVC|
    2009 R36 wagon|Biscay Blue|RVC|Tailgate|ECU and DSG tune|LED DRL/Indicators|3D colour cluster|Quad LED tail rings|Climatronics upgrade|Dynaudio retrofit|B7 RLine Flat Steering Wheel|3AA CCM|TPMS Direct|B7 Adaptive Cruise with Front Assist|Discover Media retrofit|PLA 2.0|Lane Assist|BCM retrofit|High Beam Assist|DQ500

  7. #7
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter
    Hey kamold - Again, thanks for your help on this. Just wondering do you know of any more comprehensive guides for entering and using SWDL mode via serial/telnet? Google doesn't seem to come up with anything, and to be honest I'm not even sure which pins are which that I need to connect the USB to TTL to.

    Thanks again!

  8. #8
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter
    Replaced with new comment below.
    Last edited by leifalbor; 27-12-2021 at 04:52 PM.

  9. #9
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter
    Another update.

    Thankfully I've been able to set everything up with the MMX head unit sitting in my glove box still wired into the car - so haven't had to set up a test jig on a benchtop. I'm up and running with terminal via PuTTY.

    Dr Google found me documentation showing the location of TX and RX serial debug pins -> MIB2 High - Nvidia - Recovery ifs-root.uifs via bench access - PDFCOFFEE.COM

    Two things of note: It seems there's two sets of TX/RX pins. One shown as MMX and one shown as RCC. Which ones am am I supposed to use?

    Second thing of note - these instructions show how to flash an IFS file. The firmware file I have is the usual one with the metainfo2.txt file and a heap of folders. Does anyone have instructions on how to flash that?
    Last edited by leifalbor; 27-12-2021 at 04:51 PM.

  10. #10
    Join Date
    Dec 2021
    Location
    Launceston, TAS
    Posts
    9
    Users Country Flag Thread Starter

    Duplicate post
    Attached Thumbnails Attached Thumbnails Discover Pro (MIB2.5) Stuck on boot splash screen-untitled-jpg  
    Last edited by leifalbor; 27-12-2021 at 04:53 PM. Reason: Duplicate post

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
| |