Results 1 to 6 of 6

Thread: Engine not turning off - ignition issue

  1. #1
    Join Date
    Apr 2011
    Location
    South Yarra
    Posts
    199
    Users Country Flag

    Engine not turning off - ignition issue

    Hit with several issues all around the same time - just have to work through them.

    Couple of days ago key fob working sporadically! Tried the spare key fob - same thing! Replaced both key fob batteries to rule that out. Issues with locking and unlocking vehicle using a key fob. Of course the issue that surprised me was when I stopped to park the vehicle last night and pulled the key fob out - the engine was still running!!! Suspect a switch inside the fob receiver (ignition module?) is sticking???

    Any thoughts on what to do next?
    Last edited by Deep Blue; 17-07-2023 at 05:28 PM.

  2. #2
    Join Date
    Apr 2011
    Location
    South Yarra
    Posts
    199
    Users Country Flag Thread Starter
    The thing here is there is absolutely no resistance to the fob when this happens - the fob just slides in/out of the slot freely. I'm assuming there is some sort of mechanical switch that is activated when the fob slides in/out of the ignition module. Is this common?

    Not entirely sure how to strip this down and inspect/remove/replace the key-fob receiver/ignition module (part number)? Any ideas here?

    Assuming this issue is linked with not being able to lock the vehicle with either key fob?

    Thanking you all in anticipation of someone being able to point me in the right direction here?
    Last edited by Deep Blue; 17-07-2023 at 05:29 PM.

  3. #3
    Join Date
    Apr 2011
    Location
    South Yarra
    Posts
    199
    Users Country Flag Thread Starter
    There's an ignition control module I believe that sits behind the bezel where the fob is inserted. I saw a video on YouTube that shows how to remove the module after removing a fair bit of dash trim and screws. Does anyone know the part number for the module - 2009 Passat CC (357) 2.0TDI with CBBB engine?

  4. #4
    Join Date
    Apr 2011
    Location
    South Yarra
    Posts
    199
    Users Country Flag Thread Starter
    Okay, had time to check a few things (the basics) a little while ago - took the multimeter out, checked the battery - the little window was black!!! Voltage = 7.2V! New battery - all perfect, as is alternator! Previous (dead) battery was 27 months old and from RACV - 3 months beyond the warranty period; that's why I didn't initially suspect the battery because I was sure it wasn't that old!

    All good!
    Last edited by Deep Blue; 17-07-2023 at 03:27 PM.

  5. #5
    Join Date
    May 2005
    Location
    Melbourne, Mexico
    Posts
    8,960
    Users Country Flag
    Quote Originally Posted by Deep Blue View Post
    There's an ignition control module I believe that sits behind the bezel where the fob is inserted. I saw a video on YouTube that shows how to remove the module after removing a fair bit of dash trim and screws. Does anyone know the part number for the module - 2009 Passat CC (357) 2.0TDI with CBBB engine?
    I can look it up for you, need your VIN. TTY Euro in Mordialloc

  6. #6
    Join Date
    Apr 2011
    Location
    South Yarra
    Posts
    199
    Users Country Flag Thread Starter

    Quote Originally Posted by h100vw View Post
    I can look it up for you, need your VIN. TTY Euro in Mordialloc
    Thanks a lot for that - I may as well still get the part number if possible! VIN is: WVWZZZ3CZ9E532783.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
| |