Support VWWC

Results 1 to 6 of 6

Thread: MK7 TSI Heater Problem

  1. #1
    Join Date
    Jan 2018
    Location
    Sydney
    Posts
    36

    MK7 TSI Heater Problem

    Hi guys just posting here again on this issue to get a second opinion before I opt for an expensive fix.
    So I've got a MK7 TSI 2013 Highline 103kw and have an issue with the heater not working, If I drive for about 20 minutes straight at good speed i'll manage to get warm air when driving if the fan speed is on 1. If i up the fan speed higher it'll the air will go cool pretty quickly. If I end up idling a bit at a set of lights or in traffic it'll also go back to mildly lukewarm/cool.
    Scanning the car it doesn't come up with any errors. I had my coolant system flushed and my heater core backflushed and topped with new coolant. My car oil gets to 90 degrees and sits there ok.
    Upon taking it to VW for diagnostic they weren't really sure but suggested a $1500 heater core replacement, just wondering If I can get another opinion before forking that money over incase it doesn't fix it.
    Google says something about a heater control valve/blend doors but not sure how I can check that.

  2. #2
    Join Date
    Dec 2011
    Location
    Pacific Paradise QLD
    Posts
    7,194
    Users Country Flag
    Quote Originally Posted by Clinton View Post
    Hi guys just posting here again on this issue to get a second opinion before I opt for an expensive fix.
    So I've got a MK7 TSI 2013 Highline 103kw and have an issue with the heater not working, If I drive for about 20 minutes straight at good speed i'll manage to get warm air when driving if the fan speed is on 1. If i up the fan speed higher it'll the air will go cool pretty quickly. If I end up idling a bit at a set of lights or in traffic it'll also go back to mildly lukewarm/cool.
    Scanning the car it doesn't come up with any errors. I had my coolant system flushed and my heater core backflushed and topped with new coolant. My car oil gets to 90 degrees and sits there ok.
    Upon taking it to VW for diagnostic they weren't really sure but suggested a $1500 heater core replacement, just wondering If I can get another opinion before forking that money over incase it doesn't fix it.
    Google says something about a heater control valve/blend doors but not sure how I can check that.
    Are you sure its oil at 90 normally its coolant at 90 as shown on dash and oil is often at 105/110 and ISNT shown on dash
    2021 Kamiq LE 110 , Moon White, BV cameras F & B
    Mamba Ebike to replace Tiguan

  3. #3
    Join Date
    Jan 2018
    Location
    Sydney
    Posts
    36
    Thread Starter
    Yeah I meant oil my bad. Just wondering I want to feel the 2 pipes to the radiator core to see if one side is cold and on youtube can see it's under the passenger seat you can access it behind the glovebox. Just wondering if this is the same on RHD vehicles?

  4. #4
    Join Date
    Apr 2012
    Location
    Sydney, NSW
    Posts
    123
    Users Country Flag
    Quote Originally Posted by Clinton View Post
    Upon taking it to VW for diagnostic they weren't really sure but suggested a $1500 heater core replacement, just wondering If I can get another opinion before forking that money over incase it doesn't fix it.
    Is that the complete price including labour?
    MY17 Volkswagen Tiguan 162TSI Highline, DAP, Sunroof, Caribbean Blue
    MY13 Volkswagen Golf 103TSI Highline, Night Blue

  5. #5
    Join Date
    Dec 2008
    Location
    Sydney/Canberra
    Posts
    5,521
    Users Country Flag
    There's a coolant control valve that fails meaning there's no flow to the heater core.
    '07 Transporter 1.9 TDI
    '01 Beetle 2.0

  6. #6
    Join Date
    Jan 2018
    Location
    Sydney
    Posts
    36
    Thread Starter

    Quote Originally Posted by Umai Naa!! View Post
    There's a coolant control valve that fails meaning there's no flow to the heater core.
    Where abouts is it? I asked them about a N82 valve but they said that's only on gti's or 1.8/2L's not 1.4 TSI.

    Also price was 1500 including parts/installation for the core.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
| |