Page 3 of 18 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 178

Thread: 2.0 FSI Poor idle when cold

  1. #21
    Join Date
    Mar 2009
    Location
    Goulburn NSW
    Posts
    180
    Thread Starter

    The BLX engine doesnt have the air pump - it really seems to be an oddball engine - it almost feels like it was built out of bits that were left on the factory floor. finding data on it is near on impossible, Ive even offered to pay many euro to some dubious character in a former soviet country for a copy of the MED9.5.1 Funktionsrahmen but even that didnt work...

    It does seem like it is trying to heat something up - the high idle and very retarded timing (25deg ATDC) I should have a look at the injection timing as well, I suspect its running rich as well during this period. The big question is why it does it only after been sitting for a while? and what is the trigger for this mode to activate. And yes the misfiring is not normal.

    MEL744 that would be awesome to get some more data to compare may the post be nice and speedy

    My daughter is talking about paying me a visit on the week end so I will get some more data while she is here and if she hasnt replaced the purge valve by then I guess I will do that as well

  2. #22
    Join Date
    Mar 2009
    Location
    Goulburn NSW
    Posts
    180
    Thread Starter
    Mel744 have you tried turning the engine off as soon as it starts and then restarting - I found that settled the idle startight away.

  3. #23
    Join Date
    May 2016
    Location
    Melbourne, Victoria
    Posts
    155
    Users Country Flag
    VCDS arrived today, will try to make a plot of it tomorrow. Haven't tried restarting it as you described - will do it another day after the car has been sitting for a while.

  4. #24
    Join Date
    May 2016
    Location
    Melbourne, Victoria
    Posts
    155
    Users Country Flag
    Alright so tried to make a log of it this morning, but it seems as though my engine (BVY) is not providing any data on MB 145. It has the MED 9.5.1 ECU - maybe I am doing something wrong. This was using the BLR label file. Here is a screenshot of what VCDS was showing me. You will notice that MB 112 is labelled as exhaust gas temp and was showing 462c when the screenshot was taken (car was running for 10 mins at this point) - which seems to match up with what your plot was showing at this time - maybe I should log this value on cold start? Also I did try switch off the engine after start and restarting it - sure enough it settled right down.

    Also since you seem to know a fair bit about these engines, where is the HPFP and how is it driven? I was initially concerned it was the problematic cam follower design as found on the GTI, but there doesn't seem to be anything located around the camshaft that could be it. No one has been able to give me a definite answer and investigations on these engines at the wreckers have been inconclusive.
    Last edited by MEL744; 17-04-2019 at 10:48 AM.

  5. #25
    Join Date
    Jul 2007
    Location
    Brissy
    Posts
    2,157
    Users Country Flag
    High pressure fuel pump is on the far right.
    It is not easily removed as on the turbo engines, the intake manifold has to come off first.

    2.0 FSI Poor idle when cold-img20190419163224-jpg
    2.0 FSI Poor idle when cold-img20190419163245-jpg
    2.0 FSI Poor idle when cold-img20190419163301-jpg
    2.0 FSI Poor idle when cold-img20190419163322-jpg
    MK4 GTI - Sold
    MK5 Jetta Turbo - Sold
    MK5 Jetta 2.Slow - Until it dies.

  6. #26
    Join Date
    May 2016
    Location
    Melbourne, Victoria
    Posts
    155
    Users Country Flag
    Thanks for that! That's a shame that you need to remove the intake manifold to get to it, but it doesn't seem like a cam follower design so should be no need to access it? Also here is the plot for measuring block 112.

    2.0 FSI Poor idle when cold-cold_start-jpg

  7. #27
    Join Date
    Mar 2009
    Location
    Goulburn NSW
    Posts
    180
    Thread Starter
    Sooty for the delays been tied up last few days. I’ll be back home to night and have a look.

    Couple of things I’ve discovered I’ve made some incorrect statements on

    When I can sit down with the computer - a lot easier to trying to do it knthe phone.. I’ll correct my mistakes I’ll also have a look at the specs of the bvy engine vs blx. You may not have any need for MB145 I’ve since discovered it’s a calculated value -

  8. #28
    Join Date
    Mar 2009
    Location
    Goulburn NSW
    Posts
    180
    Thread Starter
    Ok

    A couple of mistakes I have made...

    1. As there was no label file for the BLX engine I used the BLR Label file as well but after looking at this table Volkswagen Workshop Manuals > Golf Mk5 > Power unit > 4-cylinder injection engine (2.0 l engine, direct injection) > Technical data > Engine data The AXW label file looks like it would be a better match for me but for your BVY engine the BLR looks pretty good.

    2. I had made a comment regarding MB145 been different between when measured before the had been started when the engine runs rough and when the engine runs well - I was wrong .... I had been looking at logs made before the engine had started and after the engine had started rather than before start bad running and before start good running...

    HPFP yes in the photos above - I had considered that as a possible cause but as far as I could tell the symptom of failing pump was low fuel pressure MB103 should be fuel pressure - I cant put my finger on what the actual value should be at the moment - you can also check for leaks but noting the fuel pressure after running the engine for a few minutes, shutting it down and then watching the pressure with the ignition on Engine not running. As the fuel soaks up heat it expands and the pressure should rise for a period of time. Also noting the pressure straight after turning the engine of and then having a look after the engine cools down it should be about the same. if it drops much you have a leak.
    I did notice your enrichment factor was a fair bit different between bank one and two - its within spec but might indicate a slight manifold leak.
    Is your purge valve good? mine had a slight leak - a bit of carbon stuck in the seat was holding it open. You can do an output test for the engine (engine off) the purge valve test just cycles the valve open and closed about every 1/2 second i pulled the pipe of the carbon filter and blew through the pipe while it was doing the test and could confirm the new valve opened and closed.

    Self study program 322 has some good information about the FSI engine and pictures etc. http://www.volkspage.net/technik/ssp/ssp/SSP_322.pdf

    In VCDS go to Applications / Controller Channel Map
    type in 01 for the controler address
    select measuring values and I like the CSV file rather than the pre label file - but thats a personal preference
    hit go it will scan through and log all the measuring blocks some will be empty.

  9. #29
    Join Date
    Mar 2009
    Location
    Goulburn NSW
    Posts
    180
    Thread Starter
    Heres a Block map file from the weekend
    Dropbox - blockmap-01-06F-906-056-DE-20190420-0737.CSV - Simplify your life


    Thats interesting your exhaust temp hits 700deg or so withing 40Seconds mine is only around 150 or so.

  10. #30
    Join Date
    May 2016
    Location
    Melbourne, Victoria
    Posts
    155
    Users Country Flag

    I have been meaning to test the purge valve after hearing they are quite common failure points. Have also had an intermittent P1400 that seems to be there every time I scan the car - been meaning to get around to it again, but haven't had the time. Seems to point to a fault with the EGR; could explain the enrichment factor? Was going to take it off, check the plastic gear as it gets chewed up and clean the valve itself - if that's no good I guess I need a new EGR valve. That self study link looks very handy, will give it a read soon - first things first, need to change the oil today.

    Are there any values that would be helpful to log? Or just all of them like you mentioned?

Page 3 of 18 FirstFirst 1234513 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
| |