Results 1 to 8 of 8

Thread: 2007 T5 Whistle Noise

  1. #1
    Join Date
    Jan 2020
    Location
    NSW
    Posts
    6

    2007 T5 Whistle Noise

    Hey guys,
    Bought my van and has a whistle noise under boost. Not sure if its the turbo or what as it is hard to replicate when not driving. Anyone else had a issue like this.

  2. #2
    Join Date
    Aug 2013
    Location
    Esperance
    Posts
    175
    Users Country Flag
    Have you checked turbo boost pipe ?

  3. #3
    Join Date
    Jan 2020
    Location
    NSW
    Posts
    6
    Thread Starter
    Quote Originally Posted by Kombi View Post
    Have you checked turbo boost pipe ?
    I've checked the intercooler piping but can't see any holes. Is that what you meant or is it something different?

  4. #4
    Join Date
    Aug 2013
    Location
    Esperance
    Posts
    175
    Users Country Flag
    Yes, looks like a 2.5 dash, the plumbing has got a few o rings that might be leaking

  5. #5
    Join Date
    Feb 2008
    Location
    Adelaide,Oz
    Posts
    299
    Check the joining clips on the large piping are firmly seated everywhere

    how many k's?

    Bit more whistle than normal methinks.
    Any lost performance over 2000rpm?
    Can you access a code reader?

    I'd also take off the turbo intake pipe and check for bearing slop in the turbo.Might need to remove airbox, can't remember from last time i looked at mine
    My turbo has slop, 170K km, but doesn't whistle anywhere near that
    Last edited by Rebuild; 02-07-2020 at 08:39 AM.
    Steve
    04 T5 auto 2.5L TDI

  6. #6
    Join Date
    Feb 2011
    Location
    Newcastle
    Posts
    4,088
    Users Country Flag
    Sounds like its leaking boost. Could be anything from a pin hole in an intercooler pipe, to a split, to a hose clamp that's loose etc.
    2008 Subaru Liberty GT 'Tuned by STI' fun car RIP written off in floods July 2020. New car incoming.
    2015 Audi SQ5 family hauler

  7. #7
    Join Date
    Jan 2020
    Location
    NSW
    Posts
    6
    Thread Starter
    Quote Originally Posted by Rebuild View Post
    Check the joining clips on the large piping are firmly seated everywhere

    how many k's?

    Bit more whistle than normal methinks.
    Any lost performance over 2000rpm?
    Can you access a code reader?

    I'd also take off the turbo intake pipe and check for bearing slop in the turbo.Might need to remove airbox, can't remember from last time i looked at mine
    My turbo has slop, 170K km, but doesn't whistle anywhere near that
    Have checked the orings and clips on the intake side of intercooler and seem OK. It had 415,000km and no loss of power over 2000rpm. Goes great for what it is but the whistle is just annoying. Will pull apart and check bearing slop. Had the whole thing off but didn't check that as it was so far down and hard to get to.

  8. #8
    Join Date
    Jan 2020
    Location
    NSW
    Posts
    6
    Thread Starter

    Definitely sounds like a boost leaking but just finding where. Fingers crossed its an easy fix.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
| |